The Ubuntu Experience: Adventure in Motion

I'm still waiting for even the most modest Javscript exploit. Until you can provide it, you're not much more than a crackpot.

I'm done with you. If you can't figure it out on your own, you don't want to know bad enough.
So you can't, thanks for the verification. :rolleyes:

I don't need to look like hot shit here. I won't tell people how to pick locks that will not be fixed any time soon. Especially for people arrogant like you who are begging for answers in an insultive way. Like I said, figure it out yourself. It's alot closer that you would imagine.
I don't need to look like hot shit here. I won't tell people how to pick locks that will not be fixed any time soon. Especially for people arrogant like you who are begging for answers in an insultive way. Like I said, figure it out yourself. It's alot closer that you would imagine.

You're really annoying.
You're going on the internet saying you can break through through Linux Security Module's, I'm saying prove it. System hardening is done at a kernel level since I believe version 2.6 with the addition of cgroups. And I'm telling you, honestly, if you can find zero-day exploits through browsers which break this will make money!
You're really annoying.
You're going on the internet saying you can break through through Linux Security Module's, I'm saying prove it. System hardening is done at a kernel level since I believe version 2.6 with the addition of cgroups. And I'm telling you, honestly, if you can find zero-day exploits through browsers which break this will make money!

You don't have to break in, when the door is open. Look for an open door.
Minor Frustrations—Life Is Beautiful

The Good News Is That the Frustrations Are Minor

I ran into my first real frustrating Linux moments today, but the upshot is that it was a minor thing.

The Backstory: One of my co-workers is a bright young student teacher who, it occurred to me, might appreciate certain video files I have. So I thought to give her a copy. Strangely, though, something happened to one of the files—indeed, one of my favorites among the set—so that it experiences playback trouble, and the file cannot be copied because the issue originates with bad sectors that cannot be read or written. Normally, VLC Player fixes these problems, but on this occasion it cannot. I don't understand the nature of data degradation (it's stored on a WD Passport hard drive, if that makes any difference), but that's probably a different discussion.

So I had the all-too-brilliant (ha!) thought: I know, I'll torrent a new copy!

Problem: I haven't done much file sharing recently, and had not bothered with torrenting clients until, well, now.

Okay, I can figure this out.

The Frustrations: Ubuntu comes with a lightweight torrent client built in, called Transmission. Having never used any torrent client before, I sat and stared at the screen for a few minutes, having the, "Okay, what now?" conversation with myself.

But I'm not completely feeble. Having a brother who writes technical files for hardware and software, it suddenly occurs to me that, well, there should be a help file available, and, hell, I can certainly read a help file. Transmission's menu refers to an online help manual.



Oh, well.

Okay, so, I already know that Transmission is bare-bones, and if I'm going to torrent, I might as well dive in deeper. So I call my brother and ask him the simple question; he recommended µTorrent. In his several years of torrenting, this is, in his opinion, far and away the best.

And, hey, that sounds great. Just dive into the best option and go from there.

Problem: µTorrent for Linux is currently in Server Alpha.

Apparently, the current version is being built for Linux specifically; one can run the Windows client via WINE. There came a point, though, as I reviewed the command line instructions—yeah, right ... ask me to use Synaptic and listen to me laugh—I decided to simply fuck it and move on to something else.

And, yes, I even know how to look around for older versions. If there are older versions of a Linux-specific build, I didn't find them, or, really, any reference to them. Then again, I didn't look that deeply into the world wide web.

As longtime Ubuntu users know, the Software Center replaced Synaptic in the build and besides, as I suggested, I haven't learned how to run Synaptic properly yet. So off we go to the tidy Software Center and, what do you know, qBittorrent is getting great user reviews.

Fine, I'll work with that.

Five minutes.

Actually, less, most likely.

But within five minutes I had installed, searched, finished cussing out the thousands of irrelevant searches, and begun a download of a five-gig archive of the files I needed. All of the files. Not just the one 350 MB file that had corrupted, but three seasons' worth of British television that I did not steal in the first place. And no, I have no conscience issues about software piracy in cases like this; I'm simply replacing existing files, and yes, I know people can reasonably pick nits about that outlook.

Still, though, it was a refreshing frustration because the situation did not force me to surrender. Sure, it took me ten minutes to figure out why µTorrent wasn't ... uh ... opening? ... working? ... doing anything at all? And then I felt stupid for not having noticed it was the Server pack. And that took me all of thirty seconds to finish the self-excoriation. Cussing out the Transmission folks? Hell, things go 404 all the time; life goes on. With Apple or Microsoft, there is always a CEO to cuss out. With Linux, not so much. Ubuntu saved a decent box from the dust of sitting unused in my closet. For a system relying on open-source, which means we can expect some problems, the problems haven't been nearly as frustrating as what I run into with Windows and Apple systems.

It's not so much a matter of, "So, I have to admit ...", but, rather, something of a celebration. Seriously: Oh, your user manual is now 404? Effing bastards! Yeah, big effin' deal. Oh, right. This isn't actually the software I need. Whoops. Big effin' deal.

When these are the frustrations of using a computer, it's not so much that I will survive, but, rather, that I ought to be jumping up and down, whooping at the clouds, praising the gods of Linux. Sure, in that moment, you smack yourself in the forehead, staring at the 404 in the span of a heartbeat, but in the end, it doesn't really matter. In the end, you're going to want a stronger application than the one whose help files have gone 404, anyway.

Move on, move on.

I like cloudy days. Life is beautiful. Hell, I might be getting better files than the glitchy ones I have been keeping for five years, moving from hard drive to hard drive when circumstances demand.

And the point is that I can do this. Seems to me that nearly anyone should be able to do this. Especially if you're smart enough to pay attention to which software pack you're downloading, a faculty that apparently escapes my grasp. I mean, really, I could have skipped the whole µTorrent chapter and gone from 404 to downloading the file I wanted in under five minutes, except that I'm apparently oblivious to certain minor but important details.
I remember I wasn't crazy about using Transmission either. It just wasn't intuitive. I managed to use it, but I am not reminiscencing about it fondly...
Something About "Intuitive"

Something About "Intuitive"

So last night I ran a regular package of updates, and somehow did not notice until this evening—I hadn't used the computer today since then, relying on the Apple for this sort of thing—that the process somehow failed.

Ubuntu asked for a restart to finish the update process.

Restart failed, simply looping back to the login screen.

Shutdown failed, simply looping back to the login screen.

Each time, the little gear icon in the upper right remained red, requesting restart to finish the update process.

Grrr ....

Additionally, Ubuntu kept informing me of a problem in the Nautilus file.

I figure the two are connected.

Mumble, mumble, curse and scowl.

Oh, wait. Ubuntu is a Linux system!

I have a command terminal.

sudo reboot

Problem solved.

Well, at the very least, Ubuntu rebooted, properly as near as I can tell. The Nautilus bug notice has not returned.


I mean, I like Apple, but when you get used to the idea that things are supposed to be taken care of, it sometimes takes a moment or three before it occurs to you that, hey, you can solve this problem on your own.

I never learned a whit about Apple Terminal; I wonder how many problems I could have solved with it.

To the one, I feel kind of silly that this minor incident should count as any sort of triumph, but it still feels good to forego the part where you cuss out a bunch of software engineers you've never met, and settle the issue yourself.

Something about "intuitive" goes here.

Whatever the problem was, Ubuntu has filed at least a couple bug reports with the organization, so if it's a persistent problem, it will be fixed in the next update package.

For now, though, the mantra is: I have a command terminal.

(Having Shotts' The Linux Command Line near to hand is also a comfort, though on this occasion it was not necessary. I will confess, however, to Googling command line shutdown linux ubuntu, which results offered up at least a couple of command syntaxes that would have been sufficient.)
One Small Leap

One Small Leap ....

I've been accruing data faster than I had planned, and you're all familiar, I think, with that phenomenon. Presently, I'm not real anxious to sort out the mess of data on a 250GB external attached to my Apple machine, though I do have a blank partition on it.

Then, of course, it hit me that I left a 55GB Windows partition on the Linux machine's internal drive. As I haven't used it at all in the time I've had the computer, why not just get rid of it and reformat as a spare drive for the Linux system?

It took all of two minutes to confirm my suspicion that reformatting the partition would not be dangerous to the greater system as long as I paid attention to what I was clicking, and shortly thereafter I had myself a quarter shit-ton of new space.

This is way too easy. And far too much fun.

And I'm still going to need a new external drive. Just ... not quite yet.

(I'm old enough to remember being impressed by a 48K Atari 800. The idea of buying a multi-terabyte drive for less than the old Rana 1000 5.25 floppy drive we hooked up to the 800 just slays me.)
On the plus side ....

On the plus side ...

... I haven't encountered this problem, yet:

Randall Munroe, XKCD, July 19, 2012

To the other, it means I have a long way to go.
MKV-AVI Conversion Failure

MKV-AVI Conversion Failure

As one learns to use the terminal command line, yes, there is a feeling of empowerment. Of course, when a process fails ... er ... never mind the minor emotions.

I had cause to attempt to convert an MKV to AVI format. The command is straightforward enough:

mencoder WHR15.mkv -oac mp3lame -ovc copy -o WHR15.avi

In this case, the process failed:

Skipping frame!
Pos: 115.0s 3062f (11%) 387.84fps Trem: 1min 205mb A-V:0.088 [1490:239]

Skipping frame!
Pos: 115.1s 3065f (11%) 388.02fps Trem: 1min 206mb A-V:0.058 [1490:239]
[matroska,webm @ 0x9c1f00]Read error at pos. 28325826 (0x1b037c2)
Writing index...
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream: 1489.754 kbit/s (186219 B/s) size: 21436622 bytes 115.115 secs 3065 frames

Audio stream: 239.236 kbit/s (29904 B/s) size: 3457920 bytes 115.632 secs

The file plays just fine in MKV format; I simply wanted to try to harmonize it with the rest of the directory, which is in AVI format. File sources verify the quality, but acknowledge this particular file would not convert properly.

What is causing the failure? The result is 115 seconds of video that plays with visual distortion; the entire file runs over twenty minutes. It is easy enough to simply leave the file in its original format, but I'm curious about the bug.

Does it represent data corruption? Asynchronization in the sound and video encoding?

The "Skipping frame!" message is expected, insofar as it appears in the example from which I extracted the command syntax.

As noted, the file works just fine in MKV. I find this interesting because certain problems that interfere with VLC Player's playback are within the application's capabilities to repair. However ... hmm ... maybe I need to run it alongside VLC's activity log and see what that says.

Still, though, the issue has piqued my curiosity. What sort of error is causing the mencoder failure? Is it something that can be repaired?

As noted, it's not a playback problem. More to the point, it's a chance for me to learn a little more about how computers and files operate than simply being capable of running applications, opening files, and using neatly-packaged applications for workarounds. I mean, sure, I can run and protect my computers better than, say, my parents or some of my friends. But I have a geek index rating that is approximately zero.

I have this old (6+ years) laptop with some display problem. XP got nuked on it so I have Mint as OS. It hasn't been used, just was laying around. Recently I decided to upgrade it because the internet speed was just too impressive. So I ordered a new battery ($16) and two 1-1 Gb memory ($11). Using the old half giga memory Youtube wasn't playing smooth, but 1G made it alright. I figured for an extra $5 I can double that so it will have 2 Gb.

Bottomline is Linux Mint makes this pretty much useless old technology for $27 a very fast internet surfing machine. If the display annoys me I can just use it as a desktop, hooking it up to a monitor.


Mint took over Ubuntu as the most downloaded Linux distro in the last 2 months. There are still more Ubuntu users out there, but it is changing...


I was wondering just how much memory I need to run Mint smoothly:

"Currently working with Linux Mint 9 LTS which is based on Ubuntu 10.04 LTS running Compi Using 326mb of 2gb RAM"

"I'm using ubuntu 10.04 right now.I have 23 tabs open in chrome, pidgn, skype and a few text documents open and I'm using 1.5 gb of ram."
Another story: My friend's old (6+ years) business desktop was just collecting dust when he told me that he could use it as a home internet device. So I tried to wire it up, but something in XP was screwed up in the Networking and I just couldn't make it work. I wasn't even sure if I had access to the net, because the dreaded IE 6 didn't let me. So I got an idea of testing it with Linux. I quickly made a Mint 12 distro (had to be a CD install, because it has no DVD player) and sure enough the internet was flying with 20+ Mbps.
So eventually I decided to make it a dual booted machine, instead of trying to figure out what was messed up with the Networking. Oh yes, it only had 256 MB ROM, I couldn't believe it, but it was used for writing schedules and such. I put in a 1G ROM, installed Mint 12, and the machine is a super quick internet cruiser. As an extra advantage, my friend is old and this way he can't download viruses and such and won't be distracted by this file and that.

Well, since I already had the distro, I checked my older desktop and it had Mint 8 on it. Youtube was playing rather sluggish on it, so I installed Mint 12 on it too, just for good measure...
Man, I wasted a few hours while finally figuring out that the software (or the hardware?) wasn't responding to a USB keyboard. Anyhow, old business desktop running fine.

On the other hand, I have been using Linux on the laptop and FF repeatedly crashed on Imgur. I had to switch to Chromium... Not good....

Edit: For extra fun, the sound is not working on the dual booted new laptop under Linux....
Last edited:
Round Two: Apple G5 Dual

Round Two

Well, I think I've decided that over the next little while I will convert my Apple G5 Tower to a Linux build. It's dual PPC, and the OS is falling apart. It'll just take some time to settle on a build and back up various data, but I'm losing parts of the internet because network software is officially moving beyond Apple PPCs. In the end, it has to happen.

Update 13.07 PST:

Beginning Kubuntu installation on Apple G5 Power Tower with dual 2.0 PPC.

Update 16.50 PST:


Update 17.30 PST:

Install failed. How embarrassing is that? But never fear, or something like that.
Last edited:
Well, since I already had the distro, I checked my older desktop and it had Mint 8 on it. Youtube was playing rather sluggish on it, so I installed Mint 12 on it too, just for good measure...

I found another 2 desktops laying around, so I was able to make another working desktop with Mint 12 on it. So I have 2 extra ones, both are running the net fast, but they need more RAM, on half Giga Youtube is breaking up. RAM is cheap, for $16 I can buy 2G on ebay.

The only thing I don't like about Mint 12 is the slow booting time and the screen going dark for 20+ seconds. My friend has a trouble noticing that it is still booting... By the way install got stuck multiple times, I messed hours with them. Although the biggest time waster the burning a good copy of the distro was, the original just stopped working... No explanation why it stopped, sometimes the next try executed just fine...

Whenever I mess with Linux, it has to be cold and rainy outside and I expect to curse for hours... :)

Edit: Mint 12 doesn't fully work or without bugs, but just for cruising the net, it is OK. For example the screen display is screwed on the monitor, I can't fix it. Also, from the Software Manager, I couldn't install Flash or Opera. I click on Install, and nothing happens. I think Mint 10 was the last version where I got statisfied...
Last edited:
And the Winner Is ....

And the Winner Is ….

Ladies and gentlemen, boys and girls. After a long and often silly battle, the Battle of the Tower has been resolved. This post is written using Open Office, and transmitted with a very basic web browser operating under ….

Debian 6.0.6

And, heaven help us, Open Office has a mascot that pops up at random.

Oh, right.

Anyway, I need to play around with settings, and figure out what counts as intuitive, but for now the battle is won.

Kubuntu failed.

Ubuntu failed.

Mint failed.

I think part of the problem was the question of POWER4 or POWER5 architecture for PPC distributions. After cycling through various versions of PPC and AMD64(MAC) installers, the one that worked was the one I found searching specifically for a POWER4 PPC installer.

And so it goes.
Notes on Debian

Notes on Debian

I don't know what to say. It's easy enough to work with, and once I finished figuring out just how to activate the XFCE 4 desktop theme, well, sure it looks a lot like Windows, but it still looks better than the stock Gnome desktop. Holy shit, that thing is annoying.

Still, it will take some time to get used to. I forgot how spoiled I really was until I actually had to look around for something. And let me be clear: I had to look around on the screen.

I've heard rumors that Debian is not easy to get along with for novices and casual users, that it's not user-friendly. If by not user-friendly, they mean you have to go out and do certain things, like choose fonts you like, by yourself, then sure. But running inside a gui shell, it's not exactly difficult.

At any rate, it will take some time to assess the Debian experience, but yes, I'm having fun.
This post is written using Open Office,

Call me stupid, but why? Can't you just write it on this site using the browser?

Anyhow, about actually downloading with Linux, I still haven't mastered it. With Mint 10 I think, I just clicked on download, then install and it was done. Now I am not even sure which version I am supposed to download, but even when I do, after downloading it, I have to unzip programs, but no installing option comes up, thus I couldn't even install Opera and other basic things, like updating Flash....

Oh have I mentioned installing it from the Software Manager doesn't work? Anyhow, I don't really want to learn how to do it, it should be obvious and just click click click as it was in the past....
There actually is a reason

Syzygys said:

Call me stupid, but why? Can't you just write it on this site using the browser?

I've long written my posts in a text editor; it's helpful in case the browser freezes or crashes.

But I did that on my Apple. Presently, I am without an Apple desktop operating system. One consequence is that bullet points and long dashes, which are easy keystrokes on an Apple keyboard, aren't easily available to me. The long dashes can be autocorrected in LibreOffice (Ubuntu) and OpenOffice (Debian); I haven't found a text editor that will do that for me. And I'm pretty sure I can tweak bullet points back into easy keystroke, but the first thing I want to do is see if I can restore full Apple keyboard operation, so I can go back to the way I'm most comfortable typing, and the command and option buttons have some practical use instead of the stupid Alt and whatever that Windows button on the Dell keyboard I'm using right now is supposed to be for.

So I'm in an adjustment period. Life goes on, but I shall not live without my long dashes unless I absolutely must.