The Ubuntu Experience: Adventure in Motion

My 15 year old sister uses it. I even install it on a tiny little old netbook for my mother, never got a complaint. And my mother is particularly computer inept!

And I bet your mom doesn't do filesharing and downloading. She just uses the web for browsing and facebook, correct?

And that's what I said earlier, this is what Linux is good for.
And I bet your mom doesn't do filesharing and downloading. She just uses the web for browsing and facebook, correct?

And that's what I said earlier, this is what Linux is good for.

If you call bittorrent file sharing and downloading then yes she does that. Honestly the only limit I have had with Linux is games, since many are incompatible, then you can try wine but that usually painful: things get complex then. Making documents (Open office/libre Office) photoshop (gimp), audio editing (LMMS), moving watching, internet browsing, etc, all that works either out of the box or with convenient gui download database, no terminal interface needed.
Some of the older versions worked fine for me too. But the last time I tinkered with it, I couldn't even install browsers. Netsurfing was fine, but the usual click-click-click install didn't work and I didn't bother to find out what was wrong. Actually, I gave 2 computers to my friends with Linux on it, I had too many old ones in the storage.

But anyway, let's ask him again: Tiassa, are you done with Linux? Or you are going to give it another try?
Ubuntu still rocks

Oh, heavens, I'm not done with Linux. In fact, I'm using that box to listen in on NASA JPL's Curiosity teleconference while reading the headlines and posting here on the reinstalled OSX. It's actually quite convenient in that sense. I never found a good RSS reader to match Safari's, and I didn't really want to run WINE in order to get the Windows version going on the Dell. So the old G5 tower is great for Sciforums and RSS, while Ubuntu handles all my Flash and other processes the obsolete Apple can't.

As far as basic use goes, Ubuntu is more than simply up to the task. With more advanced command line and scripting functions, well, it's not like I'm making any huge effort to pick that up. I don't make New Year's resolutions, but perhaps it's worth setting some sort of Linux command fluency goal for myself this year.
Heck I'm inept at command lines, I'm gui kid, one reason I went with mint is so that I could open secure files as administrator without having to go into command line. I haven't needed to use command line for anything important except for operating R, most of the apps are gui now and if not then I don't use them.
Last edited:
Boy do I hate command lines. I never figured out how to copy commands (usual CTRL V doesn't work), so I always had to type in all the long crap...
Paint me pink and call me Nancy

ElectricFetus said:


Well, hey! That worked very well. I knew that I could right-click and paste from the menu on the command line, but, like Syz, the keystrokes for copy and paste eluded me.

Thank ye.

Well, it is at least a year too late, but thanks...

Another advice for Linux users: If you have a version that works well, don't hesitate NOT to install the newer version. Just because they release one in every 6 months (way too many) that doesn't mean you have to upgrade. I think they are at Mint 13 and Mint 8 worked just fine for me...

There is really no good reason with an already established product to come out with newer versions twice a year. Even once a year is pushing it. Sure, when the product is new, develop away, but once it has been wildly used, stop with the new versions. It is not like Windows that they have to sell the newer and newer versions....
Kind of offtopic, but I heard a very simple way how to hack password protected laptops using Linux. (let's say you forgot your password or you have just found a laptop, or your Windows crashed)

Assuming there is a BIOS password you take out the small battery from the MB. That puts the computer back to its factory default state, thus no more BIOS password. You change the booting order in the BIOS, making USB first. Then using a Linux distro on a USB stick, you install or just use Linux from the stick and from Linux you can access the files from the Windows part too. Pretty nifty trick... So much about passwords...
Ubuntu: Update Manager Issue?

Ubuntu: Update Manager Issue?

Ubuntu 12.04.01 Update Manager (ver.?) issue:

• In recent days, I've been getting a warning via the notifier in the upper right-hand corner saying the update package is out of date. I've updated the software repeatedly over the last four days, and presently, the warning is gone. However: This coincides with a /tmp mount failure after an update, and the system presently suffers a known issue (trying to find that page) in which Recovery Mode (partially) freezes during the read/write mounting process. Moving on, it turns out, is easy enough, insofar as you hit CTRL-C and the system resumes booting. Then, of course, you have to reboot regularly, and the system runs fine, except for the updater warning.

• Aside from the warning (red triangle exclamation in notifier, with drop-down explanation), which is not present at the moment, the Update Manager is not changing its last update timestamp.


It's been counting, starting at thirteen days, ever since the /tmp mount failure. And, yes, I finally managed to update the system until the Update Manager coughed out no more results.​

Is this unique to my system, or has anyone else encountered it?

Additionally, no matter how stupid I feel asking, well ... I didn't pay close enough attention until the mount failure caused me to think about it. The command line df gives me use statistics for:

— /dev/sda6 (primary drive, mount point /)
— udev (mount point /dev)
— tmpfs (mount point /run)
— none (mount point /run/lock)
— none (mount point /run/shm)
— /dev/sda1 (a storage partition, Ext3 format, mount point /media/[drivename])​

So here's the stupid question: Didn't I previously have something mounted at /tmp, thus implying that the mount failure is still in effect?

Like I said, I hadn't thought about that one way or another until after the /tmp mount failure.

I know, I know, I know. Call me a moron if you must. After all, I have now managed to lose track of my own tech issue.

I'm not worried in the long run because the system seems to be operating just fine. And I can certainly imagine that the /tmp mount failure is connected to, and possibly the source of the Update Manager issue. But, of course ... I can no longer determine the status of that issue.

Time for a cold reboot, and see how fast I can read the information blazing by.

Meanwhile, if you happen to have some input other than side-splitting laughter, I'm happy to hear it.

Ah, the Internet

Ah, the Internet — re: Update Manager Issue?

The issue is settled and resolved. Obsolete PPAs in the non-canonical update source list turned out to be the problem. In this case, a leftover scrap from a brief flirtation with the Opera web browser not removed by the USC uninstall process.

Ah, the internet. If you just enter enough search terms, you can find what you're looking for. I feel stupid for not having done this weeks ago.
Tiassa, do you have a /tmp folder at all now? Recently there was some standards conformance by the various distros towards the FHS ( whereby the "/tmp" directory should have not been mounted as a temporary file system (clears out after every restart). In which case, it might start to live on your root partition as a standard directory.

What does `cat /etc/fstab` say for you these days on Ubuntu 12.04?
(Insert Title Here)

Chipz said:

Tiassa, do you have a /tmp folder at all now? Recently there was some standards conformance by the various distros towards the FHS ( whereby the "/tmp" directory should have not been mounted as a temporary file system (clears out after every restart). In which case, it might start to live on your root partition as a standard directory.

What does `cat /etc/fstab` say for you these days on Ubuntu 12.04?

Indeed, /tmp exists on the root partition. The cat data output is as follows:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda6 during installation
UUID=b4622849-7fe7-4e28-be24-0c981af1c779 /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=4dd03533-bed2-45ab-b39e-bec4f6fab00c none            swap    sw              0       0

The system runs fine, and has since the reboot after the read/write mounting failure. The issue with the Update Manager turned out to be entirely unrelated, and future occurrences can be resolved via CLI or GUI. If I'm going to bother complaining about the USC failing to scrub the Opera PPA, I might as well start learning to code right now. Frankly, now that I know how to resolve the issue for myself, it's probably easier to just deal with it if it comes up again.

Not that there's any reason to not learn more about how to make Linux work, but neither is there any rush. To wit, when I saw that I needed to learn some sort of string or script markup to use Frescobaldi, I just downloaded the drag-and-drop MuseScore, which works well enough. All I'm trying to do with that is pen some exercises for my daughter's piano practice. As a matter of need, it's a lot quicker to get such results GUI style.
I have Mint 9 on my laptop as well as mint 14 and 9 works perfectly, 14 not so much: compiz does not work and I always hated KDE, the power button freaks the fuck out of the machine, etc, etc. Eventually I going to need to give up on 9 though.
I really don't get this fascination with 2 major updates a year. All I want for Christmas is a robust system, that WORKS. Occasionally it could get some extra this and that, but no need to have a major overhaul in every 6 months...
It was justified in the early stages, but nowadays...
Distributions ARCH, Gentoo and Slackware do rolling releases. Which more or less never deprecates your system (as long as you keep it clean). If you have 3 days to figure out how the OS really works, they are worth the effort.


Ah, Linux. Let me count the ways ....

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install cinnamon

Now it's time to play with themes and tweak the appearance. The window titles are a little silly.

Actually, I decided to play around with Cinnamon because I am preparing to rescue a PC dying under the weight of whatever Microsoft Atrocity it's running. I figured to at least learn a bit about how the environment flows.

I like it. Mayhaps I'll go desktop environment goofy; this is fun.

Last edited:
Answer Line: Freaky Girl Comin' Your Way

Scifes said:

... you're a Bronie?

I actually had to look that up.


So, to guess where the question comes from, that background is of Anarchy Stocking, a grayscaled screengrab from the opening sequence of Panty & Stocking with Garterbelt, a television show most unsuitable to "Bronies".

As close to civilized as I can get to explain:

By the way, my name's Stocking; I spoof an esteeming heiress, and I got sweet tooth for lollipops—(loli)-goth, I make good. These strips must keep you down; I got no mercy for cheeralism. My friends they all love me cause I kick it real tasty: I get high being nasty.

Garterbelt, you keep slappin' my butt around. Answer line: Freaky girl comin' your way.