Need some help :(

Not open for further replies.


We're setting you adrift idiot
Registered Senior Member
I just reformatted my Hard Drive, and after installing Winamp again I found that none of the Spectrum Analyzer or Oscilliscope graphics are working. The avs doesn't work properly, and I don't see those little bars right under the time elapsed on the main winamp window.

I'm thinking there's something wrong with my 3d card. I've got a NVIDIA TNT2 AGP graphics card with 32 mb memory. I've updated to the latest drivers for it, and I've also updated DirectX to v. 8.1 (the latest). Still it won't work.

It's not really a big problem, but I miss my winamp avs :(

Maybe I just missed something in winamp, but I don't know what it could be. If someone can help I'd appreciate it. Thanks :)
Maybe the problem is tht directx is too new.
I had a problem with one version of it.
It said tht beta time has elapssed or smth like tht and I could not run any progs tht used directx.
I messed with tht problem for a week or so. Till I discovered which.dll and other files were directx's and which registry files to delete. after a real messy procedure I was able to install 8.0 version. You know, direcrx. won't allow you to delete it or install an older version on it.
It may be not your problem though. Yust thought tht this was interesting.

I suggest you to try older TNT2 drivers or download winamp 2.77,
maybe it'll work for the new drivers.

Not much of a help from me huh!
Well the thing is, before I reformatted I was running the latest TNT2 drivers and I'm pretty sure I was on DirectX 8.1 like I am now. Maybe I should try and download Winamp 3.0, see if that will work. I dunno, I must be missing a checkbox somewhere that allows winamp to use the 3d card or something. Amazing how computers can sometimes be so stupid :(
Oh yes they smtimes are stupid! Your only hope is tht Winamp 3.0beta doesn't have tht checkbox or is totally new built without any of the old code. But I think tht problem isn't in the winamp, because you used it before with no prob. Check again the options in search for tht checkbox. Really duno,
I would hazard a guess that it's your TNT2 drivers, Logically if you've loaded the wrong ones you get errors.

I had a similar problem with my Savage4 AGP card, as there was very limited data available about the Savage4's Build.

eventually I found out it was compatible with Saveage4 GT/Pro and could use up to 32Mb texture RAM. All the drivers I had previously loaded kept erroring the Card out and also caused 3D graphics problems. The driver I eventually loaded was called a "Bit-flip" and eventually I tracked down a better driver that had been "Enhanced".

Now my system is running the graphics card smoothly, and the 3D graphics with no problem. Check your Graphics card drivers are up to date before blaming DirectX.
I have already downloaded the latest Detonator-XP drivers from NVIDIA's website. And the problem was there even before I installed the new drivers. It's weird though because I can run Freespace 2 with no problems, and it requires a 3D acceleration card to run. It seems the only problem is Winamp. But I'm on my way to download Winamp 3 now, hopefully that will solve the problem, even though it's still in Beta.
Well, I woke up today and it's working :confused:

Computers can be idiots at times. Like when I was reformatting my computer, I downloaded the drivers for my Ethernet card onto a disk. Then when it asked me to install the drivers for my new hardware (the ethenet card) I put in the disk and clicked "Have Disk".

All the required files were on the disk, and the computer wouldn't copy them because the disk was labled wrong. :confused:
" downloaded the drivers for my Ethernet card onto a disk. Then when it asked me to install the drivers for my new hardware (the ethenet card) I put in the disk and clicked "Have Disk".

All the required files were on the disk, and the computer wouldn't copy them because the disk was labled wrong."

I had the same problem with ethernet NC100v2.
But in this case do not click on -have disc- .
click on -specify a location- and browse to your OS type driver folder. it worked for me.

or if it doesn't, make a folder on your HDD and do as above.

I'm now extremely mad at my PC. all has hooked up. I can not even listen to music anymore, my monitors shuts down, unauthorized resarts etc. I have problems with my motherboard. Big problems. All electricity is fried. Dad has promissed to give me money for new PC on tuestday at last.
can not wait.
P.S. don't suggest formating. it won't help. maybe it would fix the soundcard problems but there are sooooooo many more tht it isn't important more.
A new motherboard or new PC.
I prefer new PC of course

Were you Overclocking your CPU?

I know that Overclocking has been known to fry systems, of course you'll still have people quite happily overclocking there CPU's, thinking it's really smart to increase their speed by 7% at risk of having to replace their:

Cpu, Fan, Memory, Hard-drive, Data, Graphics Card, Modem....

Personally I would rather stay at normal speed, and just risk pulling my hair out when a problem arises (although it be a trivial problem in comparison)

I admit I've done re-installs of the OS on my system, but that was after replacing the RAM to compensate for the error it had of changing the names of directories because it was BAD RAM.

Now my system is working pretty smooth, other than a few errors that are just caused through pushing too many processes at the same time on the same RAM area, but it's a less of an occurance.
no I'm not overclocking.
I have PII 333 and it is set as it.
If I waòt I can upgrade it to 350, but I know the threat you described and was aware when tuning my system.

I have a very old motherboard and it started to show some unhealthy signs some months ago. I checked it with woltimetre[spelling] and discovered tht it doesn't fully uncharge after I shut it down. There is left some free electricity.
A bit after I was changing HDD's and because I did tests I didn't position them with screws. My PC slightly moved in the testing and one of HDD wires hopped out[my fault].
There were splashes and sparks and my power box exploded[hdd survived, thank god]. I got a new one, but I think tht I damaged my motherboard even more and then started occuring different power related problems. List is long, but if you want I can list it. wanna?
Must wait till tuesday.
It's happening again :(

It worked for a while, but now it's not displaying the ocscillitory scope again. It seems like it's not getting the information from the music, the AVS works, it shows up but none of the scopes work. They are just flat lines.

Any ideas?

The way my old 486 was internally hooked up, where you have the screws that hold in the drives, I had a piece of cable that went from the screw (using a cable eye.. a flat piece of metal at the end with a hole where the screw went through) and connected to the cage. Each drive position has a small piece of cable doing that to earth the cage.

Perhaps the reason why my system doesn't suffer that is because being in England we have 3 pinned plugs (Earth, Neutral and Live) I'm not sure how many pins you have, but this does increase the static discharge.

All I can say about removing static discharge from a machine really, is to pull out your power cord as it can carry the charge (or increase the charge that is there).

everytime I've opened a computer, I've usually followed a few rules that float around. i.e. Completely uplug (including cable), and touch the cage with your hand, before tampering with anything to remove charges from yourself.

(You shouldn't mess with power on ever! or with the case missing, although I have broken those rules. :bugeye: )

I would question if you have lost RAM stabilty rather than MOTHERBOARD, but to find that out would require you to either download a program to test your RAM or for you to buy one piece and slot it in to see if your system works (and take it back to the shop afterwards)

as for Xelios you might try looking for one of the extra DirectX patches floating around. I had a problem where my mouse cursor kept creating black blocks across the screen which was fixed by a DIRECT MEDIA patch.
Hmmm, I didn't touch it and it's working again... wait, now it's not. It seems whenever the TNT2 is used for something else (such as rendering an image in Bryce) the scopes in Winamp don't work afterwards. Even if the card is not in use for anything but basic screen refreshing it won't work. Then magically it works again until I enter a game, or render an image. w333rd

I'm going to mention RAM again, I think I've come up with a Hypothesis on what is occuring...

If you load Winamp before running any other program that utilises your 3D card, the drivers and modules are loaded to a certain area of your RAM which is usually defined by how windows thinks your RAM should be assigned.

You say it works fine, but if you use Bryce before hand, Bryce has it's drivers and Modules loaded at that location, and then if Winamp is used later it is forced to use different MEMORY ADDRESSES.

I know from experience that my PIII 500Mhz system was much the Same, it would run with no errors, until more than 48Mb of my RAM was utilised (out of 192Mb of RAM), I later found that each chunk of RAM I had in the system suffered ERRORED MEMORY ADDRESSES. (Thus BSOD, and CRC compression errors which meant that any installs were Errored. this meant my Windows installation and any other software.)

I replaced my RAM but there are ways of Checking to see if this is the case. You should do a search of your 3D Card and see if there is any RAM/DRAM/SRAM checking programs.

the one I have around is called "Gold Memory", you can find a "Shareware" version from :

(I was going to attach the file, but due to legality I thought Porfiry might not like it ;) )

That should help you check your RAM, the other thing you might try is a MEMORY PURGER (Empties memory of old unwanted pieces of data that ties it up to be recycled.) I know of one that can be of use, it's from

You'll have to look through their downloads, but it's very small, and sits in the task bar.. one click and your memories purged. You could try using this after using an Application like Bryce and see if it helps Winamp.

If you want to have more control over a few things in a windows system you can Download Cacheman Http://

(Thats what I was originally using to fiddle with my RAM)

I hope this helps ;)


I also created a RAM page on:

But my Server is up and down like a YOYO! (due to NIMDA and CODE RED, just because of the logs and I've had to remove SENDMAIL to stop my SMTP being misused.)
Thanks Stryder, I'll try that. I was going to upgrade my RAM anyway, maybe I should replace what I have as well. However, at the moment I need my money for the insurance on my car, rates for young male drivers are insane...

hey everyone im pollux's sis and i dont know what im doin so dont hate him...hate me. Just sayin hi to all the sci-freaks out there.(Not meant as an insult) Um, well, have a good day!

hey everyone im pollux's sis and i dont know what im doin so dont hate him...hate me. Just sayin hi to all the sci-freaks out there.(Not meant as an insult) Um, well, have a good day!::bugeye: :confused: :bugeye: :confused:
Not open for further replies.