Copying large files to external USB crashes PC

Discussion in 'Computer Science & Culture' started by darksidZz, Jun 30, 2016.

  1. darksidZz Valued Senior Member

    Messages:
    4,920
    When using the left USB 3.0 port on the front of my case to copy a large file over to an external USB 3.0 hard drive my system completely crashes, it takes a few seconds while the file copies over and bam BSOD.

    I just noticed it now after my builds been running for awhile, everything seemed fine until this issue.

    I tried copying the same file to a USB Flash Drive and it worked, the thing didn't crash. It makes me wonder what's happening.

    I was thinking of buying myself a header to usb 3.0 adapter and checking if it works using that, it could indicate a faulty port if it does.

    I also thought to buy a USB 3.0 testing device, see how that works on the port.

    Also the biggest confusion comes from the fact I can copy large files from the hard drive fine, but copying to them crashes it?

    Any ideas for checking this out when I get home? The disk checks out using CrystalDiskInfo. I did get a few BSOD messages but forgot what they were.

    Any help appreciated

    Update: Meanwhile until I can get home to test things more I ordered these and will try them if I cannot resolve this using other means:

    DROKĀ® USB 3 0 Hub Protector Multi Tester https://www.amazon.com/gp/product/B017SOXP1Q/

    RAYSUN Dual 2 Port USB 3.0 A Type Female to 20 Pin https://www.amazon.com/gp/product/B00P5TSJK4/
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. darksidZz Valued Senior Member

    Messages:
    4,920
    I was fortunate to have another seagate usb 3.0 cable around, I swapped them out and did the copy process again this time it went normally. I am not positive the cable is the problem, it may be the port still but I am going to test using a macintosh and see if anything similar occurs.
     
  4. Google AdSense Guest Advertisement



    to hide all adverts.
  5. darksidZz Valued Senior Member

    Messages:
    4,920
    Consider this solved for now, I tested both cables again and only 1 produced BSOD errors. I am unsure why. The ports on this case are basically molded plugs that screw to the PCB controller, I don't see how they could be damaged to produce this error. I ordered new cables and will try them, I'll use that port as a backup port. I find it hard to believe the cord is bad because I tried it on the other USB 3.0 ports on the back of the motherboard and nothing occurred. It's a mystery.
     
  6. Google AdSense Guest Advertisement



    to hide all adverts.
  7. Sarkus Hippomonstrosesquippedalo phobe Valued Senior Member

    Messages:
    7,454
    It could still be the hard drive, assuming it's not solid-state. Might just depend where on the disk the file is being written to and whether there are any errors on that portion.

    I used to get frequent BSODs with the hard-disk getting most of the blame, but root cause turned out to be a faulty stick of RAM, again intermittent in creating problems.

    But I've not yet had the joys of USB 3.0, and certainly no faulty USB cables in my time. I'd have thought if it was a cable then the process would fail more times than not.

    Good luck with mystery. Hopefully it'll never return.

    Please Register or Log in to view the hidden image!

     
  8. Sylvester Registered Senior Member

    Messages:
    465
    Sounds like a bandwidth issue and your front and back ports are\may be using different drivers.
     

Share This Page